Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
2

Как написать формулу, чтобы вывести ФИО по условию?

alex0706 [13] 1 неделю назад

Создание таблицы эксель для викторины.

8 столбцов (B2:I2) - имена игроков

В10:I10 - количество правильных ответов в сумме

Надо определить, кто из игроков набрал больше и меньше всего баллов, и вывести его фамилию в ячейку

Как написать формулу, чтобы найти имя игрока, у которого наиб./наим. количество баллов?

1

=ИНДЕКС(B2:I2;0;ПОИС­КПОЗ(МАКС(B10:I10);B­10:I10;0))

"ИНДЕКС" в данном случае вернёт значение ячейки из выбранного диапазона. Диапазон задаётся первым аргументом. В данном примере это B2:I2.

0 — это номер строки в выбранном диапазоне, из которой надо вернуть значение. В диапазоне B2:I2 эта строка под индексом 0.

Следующий аргумент — номер столбца, из которого надо вернуть значение в указанном диапазоне. Столбец определяется функцией ПОИСКПОЗ, которая выполняет поиск по совпадению значений. А искомое значение определяется по максимальному значению из диапазона B10:I10. И совпадение определяется из этого же диапазона. Оставшийся нуль в функции

ПОИСКПОЗ — тип сопоставления — строгое соответствие.

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация