Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Какой формулой Excel можно посчитать сумму целых чисел заданного диапазона?

vdtest [19K] 2 недели назад
  • Как составить формулу для вычисления суммы целых чисел строки ячеек Excel?
  • Какой формулой найти сумму целых значений столбца Excel?
  • Какая формула позволяет вычислить сумму целых значений из заданного диапазона ячеек Excel?

1

Сумму целых чисел, содержащихся в заданном диапазоне ячеек удобно вычислять функцией суммы произведений двух массивов (СУММПРОИЗВ) используя в качестве первого аргумента заданный диапазон ячеек, а в качестве второго условие для целого числа, преобразованное к арифметическому значению( если ИСТИНА то 1, а если ЛОЖЬ то 0)

условие целого числа из ячейки A1 можно определить формулой:

=ОСТАТ(A1;1)=0

Результат этой формулы либо ИСТИНА либо ЛОЖЬ, для преобразования к арифметическому значению используем знак минус (-) поставленный 2 раза (первый раз ИСТИНА преобразуется к значению минус единица, второй минус меняет знак минус единицы на противоположный)

Если исходные числа записаны в диапазоне B2:B6 то формула суммы целых чисел примет вид:

=СУММПРОИЗВ(B2:B6;--(ОСТАТ(B2:B6;1)=0))

Пример использования

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация