Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Какой формулой Excel определить есть ли частичное совпадение текста ячеек?

vdtest [17.5K] 1 неделю назад
  • Как определить есть ли в двух текстовых ячейках одна и та же подстрока?
  • Каким условием узнать есть ли частичное совпадение текста в ячейках таблицы Excel?
  • Какой формулой сравнить две текстовые ячейки на совпадение части текста?
  • Как сделать сравнение ячеек на совпадение части текста?

1

Сначала выясним что такое частичное совпадение?

В одних случаях это может быть один символ, а в некоторых и много символов, поэтому в формуле придётся задавать какое количество общих символов идущих в одном и том же порядке можно найти в текстах двух ячеек.

Например в тексте разных ячеек написан номер телефона, как определить обе ячейки содержат один телефон или разные.

Поэтому придётся задать минимальное количество символов подстроки (например в колонке C), которая должна содержаться в каждой ячейке.

Если сравниваемые строки находятся в колонках A2 и B2 то составим алгоритм работы формулы:

  1. Найти в B2 подстроку ячейки A2 заданной длины и повторить операцию смещая каждый раз начало подстроки на 1.
  2. Если подстрока нашлась, то записываем индекс найденной строки, иначе 0
  3. суммируем все индексы
  4. если сумма >0 то обе ячейки имеют общую подстроку заданной длины.

Записываем это в виде формулы массива:

=СУММ( ЕСЛИОШИБКА( НАЙТИ( ПСТР(A2; СТРОКА( ДВССЫЛ("1:"&ДЛСТР( B2 )-C2)); C2); B2); 0))>0

результат либо "ИСТИНА" либо "ЛОЖЬ"

Пример работы формулы:

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID