Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
1

Как посчитать количество цифр в ячейке Excel?

vdtest [18.3K] 9 месяцев назад

Как узнать сколько цифр записано в ячейке Эксель?

Какой формулой найти количество цифр в ячейке Excel?

Как определить сколько цифр содержится в тексте ячейки электронной таблицы?

2

Для определения количества цифр потребуется формула массива, которая заполнит массив значениями истина для цифр и ложь в остальных позициях.

Если к логическому значению прибавить 0, то значение ИСТИНА превратится в 1, а значение ЛОЖЬ превратится в 0 и общее количество цифр определится как сумма элементов массива.

Сначала создаём массив символов и каждый символ ищем в строке цифр "0123456789",

если произошла ошибка то ставим значение ЛОЖЬ, а если нет то проверяем что значение >0 и получаем значение ИСТИНА

Формула массива для подсчёта количества цифр в тексте ячейки A2:

=СУММ( ЕСЛИОШИБКА( НАЙТИ( ПСТР(A2; СТРОКА( ДВССЫЛ("1:"&ДЛСТР( A2 )));1); "0123456789")>0; ЛОЖЬ)+0)

Пример работы формулы массива:

Формулы массива вводятся также как обычные формулы, но ввод завершается нажатием комбинации клавиш CTRL+SHIFT+ENTER Подробнее о формулах массива

0

Количество цифр в ячейке равно общему количеству символов за вычетом количества символов той же строки, но без цифр.

Используем функцию подставить для исключения цифр из строки по одной (всего десять замен цифры на пустую строку).

можно составить очень длинную формулу для ячейки A2:

=ДЛСТР(A2)-ДЛСТР( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ( ПОДСТАВИТЬ(A2;"0";""­); "1";""); "2";""); "3";""); "4";""); "5";""); "6";""); "7";""); "8";""); "9";""))

при копировании формулы в свой проект не забудьте заменить ячейку A2 на ячейку своего проекта.

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация