Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Как в формуле EXCEL задать регулярное выражение с подстановочными знаками?

vdtest [16K] 1 неделю назад
  • Как в формуле Эксель задать условие, чтобы определить, содержится ли в ячейке текст соответствующий одному или нескольким текстовым шаблонам?
  • Как в Excel проверить текст ячейки на соответствие регулярному выражению?
1

В Экселе всего три подстановочных знака:

  1. знак звёздочка (*) означает любой символ в любом количестве
  2. вопросительный знак (?) означает всего один любой символ
  3. знак тильда (~) означает что следующий символ не является подстановочным знаком (используется для включения в шаблон выражения служебных знаков).

Подстановочные знаки можно использовать в функциях СЧЁТЕСЛИ,СЧЁТЕСЛИМН,­СУММЕСЛИ,СУММЕСЛИМН

для определения записан ли в ячейке A2 телефон можно использовать формулу:

=СЧЁТЕСЛИ(A2; "*тел*(*"))>0

результат функции СЧЁТЕСЛИ равен 1 если в ячейке содержится телефон иначе ноль.

Если требуется соответствие сразу нескольким шаблонам можно использовать СЧЁТЕСЛИМН

для определения есть ли в ячейке телефон и инициалы клиента можно использовать формулу:

=СЧЁТЕСЛИМН(A2; "*тел*(*"; A2; "*?.?.*")>0

если требуется найти строку в которой имеется соответствие хотя бы одному выражению то удобно использовать сумму функций СЧЁТЕСЛИ

формула

=СЧЁТЕСЛИ(A2; "*тел*(495)*" )+СЧЁТЕСЛИ(A2; "*тел*(499)*" )>0

даст результат ИСТИНА если в ячейке содержится телефон с кодом 495 или 499

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID