Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
1

Сколько 5-значных чисел, у к-ых сумма первых двух цифр вдвое меньше см..?

ВЕМ [144K] 1 неделю назад

суммы двух последних цифр?

0

Из 5-значного числа рассматриваются только 2 первых цифры и 2 последних средняя цифра может принимать одно из 10 значений (от 0 до 9), следовательно общее количество пятизначных чисел будет в десять раз больше количества четырехзначных чисел у которых сумма первых двух цифр вдвое меньше суммы двух последних цифр.

Эксель:

В ячейку A1 запишем минимальное четырехзначное число 1000,В ячейку A1 запишем 1001 и растянем диапазон до числа 9999.

В ячейку С1 запишем формулу которая будет давать значение 1 для нужных ячеек:

=ЕСЛИ( (ЗНАЧЕН( ПСТР(A1;1;1)) + ЗНАЧЕН( ПСТР(A1;2;1)))*2 = (ЗНАЧЕН( ПСТР(A1;3;1)) + ЗНАЧЕН( ПСТР(A1;4;1))) ;1;0)

Растянем формулу на весь диапазон чисел

Подсчитаем количество ячеек со значением 1: =СЧЁТЕСЛИ(C1:C9000;"­=1")

или суммируем ячейки: =СУММ( C1:C9000 ; "=1" )

результат будет один и тот же 225

225*10=2250

Ответ количество пятизначных чисел, у которых сумма первых двух цифр вдвое меньше суммы двух последних цифр равно 225*10=2250

0

Для вычисления составим программу:

s=0; ////искомая сумма

for(i=10000;i<100000­;i++){

is=i.toString(10);

i1=eval(is.substr(0,­1)+"+"+is.substr(1,1)­);/////сумма первых цифр

i2=eval(is.substr(3,­1)+"+"+is.substr(4,1)­);/////сумма последних цифр

if(i1*2==i2)s++;

};

alert("s="+s)

делаем букмарклет для запуска из браузера, удаляя комментарии и разрывы строк:

javascript:s=0;for(i­=10000;i<100000;i++){­is=i.toString(10);i1=­eval(is.substr(0,1)+'­+'+is.substr(1,1));i2­=eval(is.substr(3,1)+­'+'+is.substr(4,1));i­f(i1*2==i2)s++;};aler­t('s='+s)

запускаем из адресной строки браузера:

результат на экране:s=2250

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID