Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Как в Excel разбить число на несколько ячеек, если число записано формулой?

vdtest [15.3K] 2 недели назад

Если в ячейке Excel число (или текст), записано формулой, то инструмент "Текст по строкам не работает": "Мастер текстов" Экселя видит только формулу, а не результат.

Примерно так:

Как разделить число в ячейке на отдельные ячейки?

  • по цифрам
  • по разрядам
  • по числам, преобразуя каждую цифру в число

категория: образование
2

Довольно часто требуется разбивать текст из ячейки эксель по столбцам (или по строкам).

Чтобы разделить содержимое ячейки по столбцам(строкам) придется использовать формулу, которая запишет один символ ячейки в столбец, а потом эту формулу придется растянуть на все столбцы (строки).

Если исходная ячейка B3, а разворачивать по столбцам надо начиная с ячейки D3 то

формула для записи одной позиции по символам будет такой:

=ПСТР($B3 ; СТОЛБЕЦ() - СТОЛБЕЦ( $D3 ) + 1 ; 1)

формула для записи одной позиции по числам должна учитывать, что если в определенной позиции записан символ разделитель, а не число, то преобразовывать не нужно:

=ЕСЛИОШИБКА( ЗНАЧЕН( ПСТР($B3 ; СТОЛБЕЦ() - СТОЛБЕЦ( $D3 )+1 ; 1)) ; ПСТР( $B3 ; СТОЛБЕЦ() - СТОЛБЕЦ( $D3 )+1 ; 1))

Для получения формул для развертывания по строкам необходимо заменить функцию СТОЛБЕЦ() на функцию СТРОКА().

Формулы для развертывания, начиная со строки B6:

формула для записи одной позиции по символам будет такой:

=ПСТР(B$3 ; СТРОКА() - СТРОКА( B$6 ) + 1 ; 1)

формула для записи одной позиции по числам должна учитывать, что если в определенной позиции записан символ разделитель, а не число, то преобразовывать не нужно:

=ЕСЛИОШИБКА( ЗНАЧЕН( ПСТР(B$3 ; СТРОКА() - СТРОКА( B$6 )+1 ; 1)) ; ПСТР( B$3 ; СТРОКА() - СТРОКА( B$6 )+1 ; 1))

эти формулы надо растянуть на все ячейки диапазона развертывания

После копирования формул с этой страницы сайта "Большой Вопрос" не забудьте заменить исходную ячейку (B3) и ячейки начала диапазонов развертывания (D3 и B6) на ячейки своего проекта.

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID