Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
1

Как записать программу в среде КуМир?

Coffee and Maths [301] 2 месяца назад

Робот должен закрасить самую правую клетку коридора и вернуться в исходную позицию в левом конце коридора.

Составьте недостающую часть программы на языке КуМир, используя цикл пока дважды.

Кодирование ответа для тестирующей системы:

Программу записать в одну строку без пробелов,

скобок и запятых, используя следующие сокращения (буквы русские):

нпУСЛ — нц пока УСЛ, где УСЛ — условие, сформулированое по правилам, описанным ниже

к — кц

еУСЛ — если УСЛ, где УСЛ — условие, сформулированое по правилам, описанным ниже

т — то

в - все

П — вправо

Л — влево

В — вверх

Н — вниз

З — закрасить

Правила формирования условия:

ПВ — сПрава сВободно

ПТ — сПрава сТена

ЛВ — сЛева сВободно

ЛТ — сЛева сТена

Формирование составного условия:

ПВЛТ — справа свободно И слева стена

ПВ+ЛТ — справа свободно ИЛИ слева стена

ПВЛТ+ЛВПТ — справа свободно И слева стена ИЛИ слева свободно И справа стена

неПВ — НЕ справа свободно

При составлении составных условий помните про приоритеты операций И, ИЛИ, НЕ.

категория: образование
0

самый простой способ записать программу в среде КуМир

это взять листик бумаги карандаш и резинку что бы корректировать допущенные ошибки

НЕ. самый высокий приоритет отрицания (политики так отрицают все обвинения)

И, обычное умножение приоритет ниже отрицания (политики используют только для своих денег)

ИЛИ, обычное сложение приоритет ниже умножения (политиками не используется вообще)

и вообще библия рекомендует не сотворить себе КуМир-а

0

С среде программирования Кумир Стандарт программа для выполнения указанных действий будет выглядеть следующим образом:

использовать Робот

алг

нач

нц пока справа свободно

если справа свободно

то

вправо

все

кц

если справа стена

то

закрасить

все

нц пока слева свободно

если слева свободно

то

влево

все

кц

кон

Если вставите приведенный текст программы в Кумир, она автоматически отформатируется в соответствии с правилами языка.

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID