Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
1

Как составить формулу в Excel?

TOHHMAN [4] 7 месяцев назад

Пожалуйста, подскажите, можно ли в Exel сделать формулу, которая вычисляет разницу трех чисел (коэффициент или как правильно называется) и затем от меньшего числа отнимает этот коэффициент и выводит в отдельную ячейку новое число.

Пример: есть три числа

1) 7100

2) 7550

3) 8000.

Между ними разница в 450 (коэффициент это или как назвать эту разницу, не знаю)

Затем от меньшего числа ( в данном случае это 7100) отнимается вычисленный коэффициент и в новую ячейку записывается число - 6650.

Коэффициент и числа всегда разные. Еще пример:

1) 8200

2) 9100

3) 10000.

В данном случае разница чисел (коэффициент) будет равен 900.

Затем от 8200 отнимаем 900 и новое число показывается в новой ячейке - 7300.

Спасибо.

Barmaglot [3.4K]
1) В математике пока еще не изобрели такую вещь, как "разница трех чисел"
2) Формулы в Excel составляются ТОЛЬКО ПОСЛЕ ТОГО, как становится понятной идея: что и как нужно вычислить?
3) Формулы записываются стандартными математическими обозначениями, большинство которых изучают в первом классе начальной школы.
 7 месяцев назад
комментировать
1

составим формулу, которая будет действовать только если попарные разности элементов равны, а если попарные разности элементов между ними не равны то напишем "разности различны " и далее разности чисел.

Если заданные числа записаны в ячейках A4,A3,A2 то формула будет такая:

=ЕСЛИ(A4-A3 = A3-A2 ; A2-(A3-A2) ; "разности различны: "&(A4-A3) & "<>" & (A3-A2))

автор вопроса выбрал этот ответ лучшим
1

Ваши тройки чисел образуют арифметическую прогрессию. Разность между двумя соседними членами арифметической прогрессии (то, что Вы пытались назвать "коэффициентом") так и называется "разность". Для того, чтобы вычислить её достаточно двух чисел, третье не нужно.

Допустим, что Ваши три числа записаны в ячейках А3, А4, А5. В ячейке В3 вычисляете разность по формуле =А5-А4 или =А4-А3. Затем в ячейку А2 записываете формулу А2=А3-В3.

Если само значение разности Вам не нужно, то в ячейке А2 сразу можно записать так:

=А3-(А4-А3), что эквивалентно такой записи =2*А3-А4.

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID