Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
1

Как сделать в Excel функцию?

TOHHMAN [4] 8 месяцев назад

суть такая. Есть 3 числа.

1) 5600,

2) 7200,

3) 8800.

Коэффициент, или как правильно его назвать между этими цифрами - 1600.

Далее необходимо от числа 5600 отнимать вычисленный коэффициент и будет новое число - 4000.

Как это автоматизировать ( не считать самостоятельно, возможно ли такое в Exel)

Все время числа разные, но их всегда три. И коэффициент (разность между числами) разный получается.

Еще один пример:

1) 7100,

2) 7550,

3) 8000.

Коэффициент (разница между числами 450), нужно что бы вычислялось автоматически.

И затем от меньшего числа (в данном случае 7100) отнимался этот коэффициент и должно в новой ячейке появляться число 6650?

1

В приведенных примерах надо составить формулу нахождения предшествующего элемента арифметической прогрессии.

Сначала надо установить что делать если заданные 3 числа не образуют арифметическую прогрессию и попарные разницы между ними не равны, например, в этом случае формула напишет "разницы различны"

Если три числа записаны в ячейках A2,A3,A4 то формула будет такая:

=ЕСЛИ(A4-A3 = A3-A2 ; A2-(A3-A2) ; "разности различны")

автор вопроса выбрал этот ответ лучшим
Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID