Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Как в EXCEL получить HTML код записи десятичного числа в развернутом виде?

vdtest [11.7K] 7 месяцев назад
тэги: excel, html, формула
категория: образование
1

Если само число находится в ячейке B1, а формула записывается в ячейку B2, то получить код HTML можно по формуле:

=ЕСЛИ( ДЛСТР( ТЕКСТ($B$1 ; "#")) - СТРОКА() + СТРОКА($B$2) - 1>=0;ЕСЛИ( СТРОКА()<>СТРОКА( $B$2 ); B1 & "+" ; "") & ПСТР(ТЕКСТ($B$1;"#") ; СТРОКА() - СТРОКА($B$2) + 1;1) & "*10<sup>" & (ДЛСТР( ТЕКСТ( $B$1;"#")) - (СТРОКА()- СТРОКА($B$2)+ 1))& "</sup>" ; "")

Формулу растягивают на столько строк сколько в числе десятичных позиций или больше, в этом случае получаются пустые строки.

результат получается в виде

1*10<sup>9</sup>+2­*10<sup>8</sup>+3*10<­sup>7</sup>+4*10<sup>­6</sup>+5*10<sup>5</s­up>+6*10<sup>4</sup>+­7*10<sup>3</sup>+8*10­<sup>2</sup>+9*10<sup­>1</sup>+0*10<sup>0</­sup>

что даёт такое отображение в браузере

Формула для текстового представления числа в развернутом виде приведена в ответе на вопрос Как сделать формулу EXCEL для записи десятичного числа в развернутом виде?

1

Формула для получения HTML кода развернутого вида числа произвольной длины

Исходное число записывается в ячейку В1 , а формула в ячейку B2, далее формула растягивается вниз.

=ЕСЛИ( ДЛСТР( $B$1) - СТРОКА() + СТРОКА($B$2) - 1>=0 ; ЕСЛИ( СТРОКА()<>СТРОКА( $B$2 ) ; B1 & "+" ; "") & ПСТР($B$1 ; СТРОКА() - СТРОКА($B$2) + 1 ; 1) & "*10<sup>" & (ДЛСТР( $B$1) - (СТРОКА()- СТРОКА($B$2)+ 1))& "</sup>" ; "")

Пример результата для числа 9876543210

9*10<sup>9</sup>+8­*10<sup>8</sup>+7*10<­sup>7</sup>+6*10<sup>­6</sup>+5*10<sup>5</s­up>+4*10<sup>4</sup>+­3*10<sup>3</sup>+2*10­<sup>2</sup>+1*10<sup­>1</sup>+0*10<sup>0</­sup>

Пример отображения в браузере

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID