Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Какой формулой EXCEL можно вычислить название времени года?

vdtest [11.1K] 4 месяца назад

Как внести времена года в эксель

Как определить правильное время года в EXCEL

Как сделать чтобы в документе всегда было написано правильное время года

2

=ВЫБОР(МЕСЯЦ(A1);"Зи­ма";"Зима";"Весна";"В­есна";"Весна";"Лето";­"Лето";"Лето";"Осень"­;"Осень";"Осень";"Зим­а")

Разумеется, ячейка А1 (и остальные, содержащие дату, в которой нужно определить сезон), должна быть в формате "Дата".

система выбрала этот ответ лучшим
0

Чуть короче формула (так, чисто для разнообразия):

=ЕСЛИ(ИЛИ(МЕСЯЦ(A1)<­3;МЕСЯЦ(A1)=12);"Зима­";ВПР(МЕСЯЦ(A1);{3;"В­есна":6;"Лето":9;"Осе­нь"};2;1))

также позволяет зная дату определить к какому времени года она относится. Наверное, формула будет интересна, прежде всего тем, кто любит альтернативные решения одной и той же задачи (в данном случае задачи о том, как формулой Excel узнать название времени года на основании имеющейся в ячейке даты).

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID