Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
0

Как в Excel из числа получить числитель и знаменатель несократимой дроби?

vdtest [8.3K] 2 недели назад

Как сделать дробь в эксель?

Можно ли формулами, в ячейках Эксель, любое десятичное число представить в виде целой части и обыкновенной несократимой дроби: числителя и знаменателя?

Дробь

категория: образование
1

Чтобы представить десятичное число в виде десятичной дроби надо определить все части обыкновенной дроби это Целая часть, Числитель и Знаменатель, которые, затем можно написать в виде целых чисел в различных ячейках.

Чтобы целая часть располагалась посередине дроби необходимо объединить две ячейки.

При составлении формул необходимо определить количество десятичных знаков, для этого можно представить число в виде текста по формуле =ТЕКСТ(A2;"0.#####­######"), формат преобразования выбирается из условий задачи(например формула **=ТЕКСТ(A2;"0.##")*­* преобразует число к числу с двумя десятичными знаками)

числитель определяется как число после десятичного разделителя, а знаменатель как 10 в степени количества знаков дробной части

после определения числителя и знаменателя необходимо поделить и числитель и знаменатель на величину наибольшего общего делителя, используя функцию НОД(Числитель;Знамен­атель)

Если задано целое число то необходимо записать вместо числителя и знаменателя пустые строки

Если исходное число записано в ячейку A1 то получаем такие формулы:

Целая часть

=ЦЕЛОЕ(A1)

Числитель

=ЕСЛИ(ДЛСТР(ТЕКСТ( A1;"0.###########"))­-ПОИСК(".";ТЕКСТ( A1;"0.###########"))­>0;ЗНАЧЕН(ПСТР(ТЕКСТ( A1;"0.###########");­ПОИСК(".";ТЕКСТ( A1;"0.###########"))­+1;ДЛСТР((ТЕКСТ( A1;"0.###########")-­ПОИСК(".";ТЕКСТ( A1;"0.###########"))­))))/НОД(ЗНАЧЕН(ПСТР(­ТЕКСТ( A1;"0.###########");­ПОИСК(".";ТЕКСТ( A1;"0.###########"))­+1;ДЛСТР((ТЕКСТ( A1;"0.###########")-­ПОИСК(".";ТЕКСТ( A1;"0.###########"))­))));СТЕПЕНЬ(10;ДЛСТР­(ТЕКСТ( A1;"0.###########"))­-ПОИСК(".";ТЕКСТ( A1;"0.###########"))­));"")

Знаменатель

=ЕСЛИ(ДЛСТР(ТЕКСТ(A1­;"0.###########"))-ПО­ИСК(".";ТЕКСТ(A1;"0.#­##########"))>0;СТЕПЕ­НЬ(10;ДЛСТР(ТЕКСТ(A1;­"0.###########"))-ПОИ­СК(".";ТЕКСТ(A1;"0.##­#########")))/НОД(ЗНА­ЧЕН(ПСТР(ТЕКСТ(A1;"0.­###########");ПОИСК("­.";ТЕКСТ(A1;"0.######­#####"))+1;ДЛСТР((ТЕК­СТ(A1;"0.###########"­)-ПОИСК(".";ТЕКСТ(A1;­"0.###########"))))))­;СТЕПЕНЬ(10;ДЛСТР(ТЕК­СТ(A1;"0.###########"­))-ПОИСК(".";ТЕКСТ(A1­;"0.###########"))));­"")

При копировании длинных формул с этой страницы в Excel могут появляться лишние символы (см Как скопировать формулу Excel из интернета, чтобы она работала?).

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID