Вход
Быстрая регистрация
Если вы у нас впервые: О проекте FAQ
2

Как посчитать количество уникальных значений в Excel?

Ксарфакс [145K] более года назад

Подсчет уникальных значений в Экселе (Excel).

Как в Excel можно посчитать количество уникальных значений в столбце или определенном диапазоне?

Excelskype [3K]
есть три формулы: первая считает только к-во уникальных для диапазона в котором текст, вторая - для диапазона в котором числа, третья - могут быть и числа и текст. Также еще важно чтобы в диапазоне не было значений ошибок, а еще, чтобы в диапазоне не было пустых ячеек... Так Вам какой вариант формулы написать в ответе? )
Кстати, можно же еще посчитать и неформулами, а, например, сводной таблицей..
 более года назад
Ксарфакс [145K]
Интересует два варианта:
1) Диапазон ячеек, в которых содержатся только числовые значения.
2) Диапазон ячеек, в которых содержатся только текстовые значения.
 более года назад
комментировать
1

Под уникальными значениямм понимаем те, которые встречаются в диапазоне только один раз.

Допустим значения содержатся в диапазоне С2:С9

Водим диапазон E2:E9 в ячейках которого содержится количество повторов каждого значения в диапазоне С2:С9

Формула количества повторов для значения C2 =СЧЁТЕСЛИ($C$2:$C$9;C2)

Эта формула растягивается на весь диапазон

Повторы

Количество уникальных значений определится по формуле =СУММЕСЛИ(E2:E9;"=1")

Колич уников

Чтобы увидеть уникальные элементы нужно наложить фильтр на столбец E

система выбрала этот ответ лучшим
8

Если возникла задача посчитать количество уникальных значений в Экселе (Excel), то её можно решить несколькими способами - с формулами и без формул.

1) В том случае, если диапазон данных (числовых или текстовых) является статичным и меняться не будет, то можно воспользоваться командой "Удалить дубликаты".

Для этого выделяем диапазон (в нашем примере - это B1:B14) и на панели инструментов Excel выбираем "Данные" -> "Удалить дубликаты".

Появится окно, в котором указываются столбец / диапазон, из которых удаляются дубликаты.

Нужно, чтобы обязательно стояла галочка "Мои данные содержат заголовки" - иначе заголовок тоже будет учитываться при отборе уникальных значений.

Теперь нажимаем на кнопку "ОК".

В результате Эксель выведет сообщение о том, сколько найдено дубликатов и сколько осталось уникальных значений.

Таким образом, количество уникальных значений в выбранном диапазоне будет равно 10.


2) Для определения количества уникальных значений в Excel можно использовать специальную формулу, состоящую из 2 функций:

СУММ

СЧЁТЕСЛИ

Функция СЧЁТЕСЛИ будет использоваться для того, чтобы посчитать, сколько раз встречается то или иное значение в диапазоне.

Далее с помощью функции СУММ суммируются дроби вида:

1 / Число вхождений каждого элемента.

Для нашего примера формула будет выглядеть так:

{=СУММ(1/СЧЁТЕСЛИ(B2:B14;B2:B14))}

При этом вводить её нужно как формулу массива - через комбинацию Ctrl + Shift + Enter.

как посчитать количество уникальных значений в экселе excel

В результате получится всё те же 10 уникальных значений.

А вот примеры работы этой формулы, если в таблице Excel имеются текстовые данные:

1

Можно использовать специальную формулу для подсчёта количества уникальных значений в Excel. =СУММПРОИЗВ(1/СЧЁТ­ЕСЛИ(Диапазон;Диапазо­н)), где "Диапазон", это диапазон, в котором нужно подсчитать уникальные значения.

Например:

Имеем ряд случайных чисел. Вводим в свободную ячейку формулу. В данном случае, диапазон=A1:A10. Конечная формула: **=СУММПРОИЗВ(1/СЧЁТ­ЕСЛИ(A1:A10;A1:A10))*­*

Так же, будет работать и для подсчёта текстового варианта:

0

Под уникальными значениями понимаем те, которые не встречались ранее.

Если диапазон значений C2:C7

Вводим столбец с номером повтора в диапазоне вверх от текущей ячейки(E2:E7).

Формула вычисления повтора для ячейки C2

=СЧЁТЕСЛИ($C$2:C2;C2)

Растягиваем на весь диапазон

количество уникальных определится по формуле

=СЧЁТЕСЛИ(E2:E7;"=1")

Если нужен список уникальных значений , то надо поставить фильтр , оставляющий только те строки, у которых номер повтора равен 1

Знаете ответ?
Есть интересный вопрос? Задайте его нашему сообществу, у нас наверняка найдется ответ!
Делитесь опытом и знаниями, зарабатывайте награды и репутацию, заводите новых интересных друзей!
Задавайте интересные вопросы, давайте качественные ответы и зарабатывайте деньги. Подробнее..
регистрация
OpenID